プロジェクトのアップグレード(to 1.0 beta1)

http://www.symfony-project.com/trac/wiki/HowToUpgradeToLatestBeta
まず、以下のファイルの書き換えをする。

  • /SYMFONY => /symfony
  • /config/config.php
  • /apps/[appname]/config/config.php

...以上で、symfonyコマンドが使えるようになるので、プロジェクトディレクトリから、
symfony upgrade 1.0
を実行する。
あとは、modelのrebuildとclear-cache。
D:\sfprojects\askeet2>symfony upgrade 1.0
>> upgrade 1.0 upgrading propel.ini configuration file
# there are 2 new propel.ini options:
# - propel.builder.addIncludes
# - propel.builder.addComments
# sfConfig::get('sf_i18n_instance') is deprecated
# use sfContext::getInstance()->getI18N()
>> upgrade 1.0 upgrading require in models
# model require must be lib/model/...
# instead of model/...
>> upgrade 1.0 migrate activate to enabled
# activated_modules: is deprecated in settings.yml
# use enabled_modules:
# activate: is deprecated in cache.yml
# use enabled:
# active: is deprecated in logging.yml
# use enabled:
# sf_logging_active is deprecated in *.php
# use sf_logging_enabled
>> file- D:\sfprojects\askeet2/SYMFONY
>> file+ D:\sfprojects\askeet2/symfony
>> chmod 777 D:\sfprojects\askeet2\symfony
>> upgrade 1.0 upgrading schemas
# schema.xml must now have a database package
# default is package="lib.model"
>> upgrade 1.0 add test bootstrap files
>> dir+ D:\sfprojects\askeet2/test/bootstrap
>> file+ D:\sfprojects\askeet2/test/bootstrap/functional.php
>> file+ D:\sfprojects\askeet2/test/bootstrap/unit.php
>> upgrade 1.0 upgrading main config.php
>> upgrade 1.0 upgrading application "frontend"
>> upgrade 1.0 upgrading config.php
>> upgrade 1.0 upgrading filters.yml
# filters.yml now contains core symfony filters
>> upgrade 1.0 upgrading deprecated helpers
>> upgrade 1.0 upgrading date form helpers
>> upgrade 1.0 upgrading deprecated helpers in generator.yml
>> upgrade 1.0 upgrading cache configuration
# "type" has been removed in cache.yml
# read the doc about "with_layout"
>> upgrade 1.0 upgrading deprecated methods in actions
>> upgrade 1.0 upgrading view configuration
>> upgrade 1.0 upgrading sf/ path configuration
>> upgrade 1.0 done
>> dir+ D:\sfprojects\askeet2/plugins
# WARNING: you must re-install all your plugins
# Now, you must:
# - rebuild your model classes: symfony propel-build-model
# - clear the cache: symfony cc

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください