mavenのビルドでエラー

ソースのバージョン - TzlTTqTjの日記
mavenでのビルドで以下のようなエラーが。

[11,5] 注釈は -source 1.3 でサポートされていま
せん
(注釈を使用可能にするには、-source 5 以降を使用してください)
総称型は -source 1.3 でサポートされていません
(総称型を使用可能にするには、-source 5 以降を使用してください)

以下のように、pom.xmlにmaven-compiler-pluginのsourceとtargetを指定する。

<plugins>
	<plugin>
		<groupId>org.apache.maven.plugins</groupId>
		<artifactId>maven-compiler-plugin</artifactId>
		<configuration>
			<source>1.6</source>
			<target>1.6</target>
		</configuration>
	</plugin>
</plugins>

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください